Battlefield 4

Hi there, you have this error "To run this application, you first must install one of the following versions of the .NET Framework" when you want to play video game Battlefield 4 ? Then is very simple to solve this error, just download and install this or this for windows 7 and windows 8 of course or download and install latest version 4.5.1 RC from here or from here.

Battlefield 4

To run this application, you first must install one of the following versions of the .NET Framework

To run this application, you first must install one of the following versions of the .NET Framework

Battlefield 4 - .NET Framework initialization Error

Summary

Normally, when you buy the game, in the package is included and this prerequisite

Just install latest .net framework or .net framework 4.5.1 RC (latest version for september 2013)

Battlefield 4

Battlefield 4 video game for PC works great on my older video card ATI AMD Radeon HD 7850 2 GB with a processor Intel i5 750 overclocked to 3200 Mhz but this game have so great graphics and you need better than that. But if you want to play Battlefield 4 with maximum graphics details, then you need more power like : GeForce GTX 770 2GB with a processor : Intel Core i7 4770K with 3.5GHz

or

ATI AMD Radeon R9 280X with a processor : AMD FX-9370 4.4GHz But, if you want to play Battlefield 4 with a big screen or multi monitors, and you have money you can spend more to video card and you can buy a GeForce GTX 780Ti or AMD Radeon R9 290X (both are very expensive video cards). By the way, Battlefield 4 is running very good on Windows 8.1 64 bits.

Anyway, AMD Radeon video cards are better optimized for Battlefield 4

Troubleshooting ! More errors for Battlefield 4 ?

 Post your errors here 

Welcome to gurufixes.com !

AD


Best Premium hosting!

affiliate_link

Partners :

www.upperplace.com

www.driversnest.com

www.gurudrivers.com

www.demisia.com

www.baltaru.com

www.webcamdevice.com

www.driverstead.com

www.driverspin.com

www.google.com

Enjoy our free fixes !